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1 Starting out 

1.1 Global Settings 

When starting a new project it is best to revisit Global Settings at Edit->Global Settings to ensure that the signal parameters are set to your 
agency preferences.  Each signal created (or converted signal not containing the specified data) will have these global defaults. 

Note: Global Settings can be changed at any time during the project to adapt to multiple locations or corridors, districts, or jurisdictions with a 
project. 

Additionally, Default Signalization utilizes the Global Setting parameters when automatically setting up the traffic signal controller.  See Page 
20 for Default Signalization information. 

For the full list of Global Setting Parameters for setting up a traffic signal using HCM Methods, see Table 1-2 on Page 5.  A few additional 
parameters are available if the Canadian Capacity Guide methodology is selected as an analysis method. 

Tip: Global Settings should be reviewed and adjusted as needed before Importing a in a Synchro model, as Vistro most often includes more 
information than Synchro.  See Section 0 for more information on Synchro .csv Imports or model Merging and Updates. 

Back to top 

1.1.1 Default Signal Group scheme 

Excerpted from Table 1-2, intersections created with default signalization will use the following NEMA signal group orientation defaults for 
the major and minor flow directions, or any other agency signal group scheme. By default, Vistro follows the NEMA scheme, as shown in 
Figure 1-1 from NCHRP Report 812, Signal Timing Manual, Second Edition’s Exhibits 5-1 and 5-3. 

Table 1-1: NCHRP Report 812's NEMA Phasing Scheme 

Signal Group Scheme Parameter 
Description 

Major Flow Direction Determines if the north-south direction or the east-
west directions should be the set to the major flow. 
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Northbound Signal Group (major) If the north-south directions are the intersection’s 
major flow, this determines the default northbound 
signal group. 

North-westbound Signal Group (major) Determines the default major flow signal group for 
skewed intersections in the north-westbound 
direction. 

North-eastbound Signal Group (major) Determines the default major flow signal group for 
skewed intersections in the north-eastbound 
direction. 

Eastbound Signal Group (major) If the east-west directions are the intersection’s major 
flow, this determines the default eastbound signal 
group. 

Figure 1-1: NEMA Traffic Signal Phasing 

 

 

Table 1-2: Global Setting Parameters for setting up a traffic signal using HCM Methods 
Global Setting Parameter Default Setting Optional Setting Traffic Control Workflow  
Analysis Period 15 min 1 hr Intersection Settings 
Located in CBD Yes No Intersection Settings 
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Major Flow Direction North-South East-West Intersection Settings 
Northbound Signal Group (major) 6 2, 4, 8 Phasing & Timing 
Northwestbound Signal Group 
(major) 

6 2, 4, 8 Phasing & Timing 

Northeastbound Signal Group 
(major) 

2 4, 6, 8 Phasing & Timing 

Eastbound Signal Group (major) 2 4, 6, 8 Phasing & Timing 
Lead/Lag Setting Lead Lag Phasing & Timing 
Cycle Length (s) 90 0-255 Intersection Settings 
Coordination Type Time of Day Pattern Coordinated Time of Day Pattern Isolated, Free Running Intersection Settings 
Actuation Type Fixed Time Fully Actuated, Semi-Actuated Intersection Settings 
Offset Reference LeadGreen – Beginning of First 

Green  Beginning of Both Green;  

 Beginning of First Yellow; 

 Beginning of First Red; 

 Beginning of First Flashing Don’t 
Walk; 

 LagFO; 

 LagEnd; 

 CoordEnd; 

 Intersection Settings 

Permissive Mode Single Band Multi-Band, Reservice Intersection Settings 
Intersection Lost Time (s) 0 0-(cycle length-0.1) s Intersection Settings 
Minimum Green, Through (s) 10 0-255 s Phasing & Timing 
Minimum Green, Left (s) 5 0-255 s Phasing & Timing 
Amber (s) 3.0 0-255 s Phasing & Timing 
Allred (s) 1.0 0-255 s Phasing & Timing 
Vehicle Extension (s) 3.0 0-25.5 s Phasing & Timing 
Walk (s) 5.0 0-255 s Phasing & Timing 
Pedestrian Walking Speed (ft/s) 3.50 f/s (1.07 m/s)  Intersection Settings 

Back to top 
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2 User Interface for Traffic Signal Controllers 

2.1.1 Placing a signal refresher 

Junction Type: To place a signalized using the junction type, select the signalized intersection junction 
type from the expansion list.  Then, with the intersection placement icon displayed, left-click on the 
base map to place the junction at the desired location. 

 

-> 

 

Right-Click: A signalized intersection can be placed at the mouse position by using the Right-Click 
button on a roadway segment’s Leg or on at a location on the base map.  The right-click will open the 
context menu.  Then select Insert Intersection -> Signalized. 

 

Copy and Paste: A signalized intersection can be placed by copying and pasting an existing signalized 
intersection.  This will make an exact copy of the signal; however, the location will be assigned a new 
Intersection Number and Controller ID. This can be achieved by selecting an intersection, right-clicking 
to open the context menu, and selecting Copy Intersection.  To paste an intersection, find a desired 
location on the base map, right-click to open the context menu, then select Paste Intersection.  
CTRL+C and CTRL+V are intersection copy and paste shortcuts, respectively. 

 

-> 
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Back to top 

2.1.2 Network Graphic Parameters for Traffic Signal Parameters and Analysis 

PTV Vistro includes many graphic parameters that are useful for traffic signal controller setup and 
evaluation, as shown in Table 1-3. For example, showing signal groups in the network editor enables 
you to see exactly what movement is allocated which signal group number at the intersection creating 
strong correlations to the Phasing & Timing Tables, Phase Diagram, and Sequence. 

Table 1-1: Network Graphic Parameters useful for Traffic Signal Controller Setup and Analysis 

Graphic Parameter Toolbar Icon Description 

Show Signal Groups 

 

Shows the signal groups per approach 
movement as indicated in the Traffic Control 
Workflow, sequence, and phase diagram. 

Show Detailed Traffic 
Conditions 

 

Show movement and lane group results on 
each approach per the Traffic Control 
Workflow calculations 

Show Intersection 
Info 

 

Shows intersection information.  Regarding 
traffic signals, the controller type, controller, 
number, coordination group, cycle length, 
and intersection ICA check displays useful 
information. 

Back to top 

2.1.3 Signal Control Menu 

Next, the Signal Control menu, summarized in Table 1-4, contains the tools and lists for traffic signal 
setup, optimization, and editing. 
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Table 1-2: Signal Control Menu 

Menu Items Control Window Description 

Default 
Signalization 

 

Creates default signalization for ALL 
intersections at 1 time. 

Network 
Optimization 

 

Contains settings for network optimization 
along 1 or multiple coordination groups. 

Local 
Optimization 

 

Contains settings for local optimization and 
the option to optimize all intersections at 
one time locally. 

Edit 
Controllers 

 

Enables renumbering of Controller ID 
numbers and add controller descriptions or 
inventory information. This lists the 
associated Intersection(s) number to each 
Controller ID.  Lists can be filtered. 

Edit 
Coordination 
Groups 

 

Create, delete, and name coordination 
groups. Also, a Master Controller ID can be 
selected from a list of intersections that are 
members of each coordination group. 

Back to top 

2.1.4 Traffic Signal Workflow Table 

Traffic signal information is entered on the Traffic Control Workflow table.  The Control Type needs to 
be set to Signalized to create and edit a traffic signal controller. 
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Figure 1-1: Traffic Signal Workflow Table 

 

On this workflow table, there is a special toolbar that is useful for traffic signal optimization, calculation 
checking, and data entry.  

Figure 1-2: Traffic Signal Workflow Toolbar 

 

Menu Items Description 

ICA Check This tool checks for basic parameters used for an Intersection Capacity 
Analysis. This tool along with the graphic parameter (Show Intersection 
Info -> ICA check) provides a basic quality control check of the model.  
Clicking on this button displays warnings or critical error messages 
useful to fix the intersection’s setup.   

    

Automatic 
Optimization 

When checked, Automatic Optimization can be used to quickly optimize 
intersection, locally.  This is useful when new volume parameters, 
intersection configurations, trip distributions, assignment information, 
and other relevant parameters are entered. Default Optimization 
parameters will be taken from Global Setting and the Local Optimization 
settings under the menu Signal Control->Local Optimization. 

Default Signalization After setting the primary controls and methods, this button activates 
default signalization at the active intersection.  This generates signal 
groups based on the control types and the Sequence and Phase 
Diagram for common 3 and 4-leg intersections. Default Signalization will 
use the timing parameters defined in Global Settings and the Major and 
Minor street Priority Scheme to allocate the NEMA phasing convention.  
Min. green times and clearance intervals will be overwritten. 
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Optimize Split and 
Cycle Time 

This button activates the Local Split and Cycle Time optimization menu, 
but only for the active intersection. Intersection min. green times and 
clearance intervals are respected. Here local settings and optimization 
strategies can be selected, such as upper and lower limits to the cycle 
length, step sizes, objective functions. 

 

Optimize Split This button activates the Local Split (only) menu, but only for the active 
intersection. Intersection minimums and clearance intervals are 
respected. Here local settings and optimization strategies can be 
selected, such as upper and lower limits to the cycle length, step sizes, 
objective functions. 

 

Signal Groups Menu 
This button opens a window that lists active or inactive signal groups 
defined to the controller. In use or not, these signal groups can be 
assigned to the sequence, to movements, or auxiliary signal groups used 
in overlaps.  This window should be used for advanced intersections, 
such as multiple intersections set to 1 controller, intersections with “hold 
phases” for transit signal groups, or in the case of tight diamond 
overlaps. This window will display the signal groups in numerical order 
for easy editing and reference enable you to enter overlaps to use as a 
special Auxilary Signal Group not already assigned to a movement. 

 

Search Bar Within each workflow, a search term can be entered to filter the current 
Workflow Table. This can be useful to quickly find key parameters, 
calculation values, or results by name, partial text string, or keyword(s). 
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Workflow Pop-out Some locations require more monitor space to view numerous 
movements and information.  This button enables multi-monitor layouts 
with a full-screen experience by popping out the workflow tables.  Use 
the windows maximize button to dock the workflow display. 

Back to top 

2.1.5 Multi-Change Tool 

After intersections are created in Vistro, it may be necessary to update a single, a few, or all 
intersection parameters all at 1 time, such as clearance intervals, minimum green times, analysis 
methods, or right-turn on red methods.   The multi-change tool can be used to update key attributes 
all at once or by customizable selection sets using the list sorting and filtering functionality.  
Additionally, intersections can be viewed by coordination groups to select intersection sets by a 
corridor or district. The following is an overview of the multi-change tool. 

1. Under the Edit Menu, select Multi Change. 
2. Select the Attribute to change. 

  

3. Enter attribute value to apply to the intersection selection set 
4. Selection Filters: 

• All intersections or No intersections using the quick icons . 
• Sort ascending or descending by left-clicking on the column headers 
• Filter list by hovering over a column header and left-click the funnel . 

Back to top 
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3 Traffic signal controller setup 
The following is a list of PTV Vistro’s traffic signal controller inputs, along with a description, guidance 
on using the parameter, and the Synchro Equivalent parameter, if applicable. For more detailed 
descriptions and units of each parameter, visit the Vistro help under Chapter 8. 

Table 2-1: Typical traffic signal controller setup terminology 

Parameter Short Description Synchro 
Equivalent 

Intersection Settings 
Priority Scheme Sets which approaches are the major or minor streets.  This is 

set with Global Defaults; however, can be modified at any 
time. 

- 

Analyze Intersection? This indicates this intersection will be included in the reports. - 
Analysis Period The time period for the analysis Analysis Time Period 
Located in CBD A check box indicates the intersection is in a central business 

district. HCM for a description of the CBD area. 
Area Type CBD 

Controller ID Each signal controller has a unique ID number. This value 
defaults to the intersection number, or intersections can 
share a controller. 
To edit default Controllers IDs to another number or 
specialized agency number systems open the Edit 
Controller window under Signal Controller ->Edit 
Controllers. 
 

Node# 

Signal Coordination 
Group 

Signalized intersections of the same subgroup are 
coordinated collectively. Multiple subgroups (coordinated 
routes) are permitted. 

Zone 

Cycle Length Controller cycle length. This is the maximum time it will take 
for each signal group to cycle once. The cycle length is only 
used for coordination. 

Cycle Length 

Coordination Type Defines coordination as Free, Time of Day Pattern 
Coordinated, or Time of Day Pattern Isolated. 
 
The following describes coordination methods: 

• Free-running means that the traffic signal controller 
does not have a set cycle length and is running with 
fully actuated detection. 

• Time-of-day Coordinated sets a cycle length and 
places the controller in coordination with other 
signals in the same coordination group.  

• Time-of-day isolated sets a cycle length but does 
not place the controller in coordination with other 
signals. 

Control Type 

Actuation Type Defines whether the controller operates as: 

 Fixed-time (pre-time) control consists of 
predetermined signal timing values not based on the 
detection. 

Control Type 
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 Fully actuated: If the Coordination Type is not Free 
Running, the fixed time signal plan is used to calculate 
the Force-Off Points of the non-coordinated phases. 
The user has to provide a valid and useful fixed time 
signal plan. By modifying the signal plan, the user can 
influence the calculated Force-Off Points with 
maximum and minimum green inputs, recalls, and 
vehicle extensions. This control type sets detection on 
all lanes that influence signal operations. 

 Semi-actuated: contains some lanes with detection 
that influences signal operations. Often, the major-
street thru lanes do not operate with detection to 
generate phase calls. 

Offset When coordinated, the local cycle timer will be offset from 
the master cycle timer by the defined offset time relative to 
the reference point. 

Offset 

Offset Reference 
This is the point in the cycle where the master cycle 
timer will be equal to the defined Offset time when the 
controller is coordinated and not in transition (offset 
seeking). Further explanations can be found in NCHRP 
Report 812 – Signal Timing Manual. The selections are: 

• Lead Green – Beginning of First Green: The 
reference point will be at the start of the leading 
coordinated signal group green (the computed start 
of green, note that the signal group may return to 
green early if there is a lack of demand on opposing 
movements). 

• Beginning of Both Green – at start of 2nd coordinated 
green (both are green) 

• Beginning of First Yellow – start at first coordinated 
yellow 

• Beginning of First Red – start at first coordinated red 

• Beginning of First Flashing Don’t Walk 

• LagFO (Lagging Force-Off) – The reference point will 
be at the force-off point for the lagging coordinated 
signal group. 

• LagEnd (End of Lagging Red) – The reference point 
will be at the end of Red Clear for the lagging 
coordinated signal group.  

• CoordEnd (End of Coordinated Group Red) – The 
reference point will be at the end of red for the last 
signal group in the concurrent barrier group with the 
coordinated signal groups. 

Reference to 

http://www.trb.org/Publications/Blurbs/173121.aspx
http://www.trb.org/Publications/Blurbs/173121.aspx
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  

  

Permissive Mode 
This setting defines the permissive mode for the 
coordination pattern per NCHRP Report 812 – Signal 
Timing Manual. 
 

The permissive mode controls the method in which 
permissive periods are opened and closed for all non-
coordinated signal groups. The controller will only 
yield to signal groups that are permissive following the 
end of green on each coordinated signal group. The 
permissive modes are as follows: 

 

• Single- and multi-band modes:  The single-
band permissive mode starts all permissive 
signal groups at the same time (one band). 
The multi-band permissive mode starts one at 
a time, where the next permissive band opens 
after the last one closes (multiple bands).  

The advantage of single-band permissive mode is that, 
under light traffic volumes, there is the ability to skip 
minor street (or non-coordinated phases 4 & 8 in the 
image) and call perhaps the main street turning 
phases early (phases 1 and 5 in the example image) if 
the Phase 1 call comes before Phase 4.  This is better if 
the main street is Agency the priority and the minor 
street is not a high priority.  For “fairer” operations on 
the minor street, multi-band allows for an opportunity 
for a side street to be reevaluated and is not a first-

Yield Point 
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come-first-serve detection after the yield point 
between 1/5 and 4/8.  If detection of 4/8 comes along 
after a call on 1/5, 4/8 goes first still (if there is still time 
for the call to be considered and not skipped).   

 

• Reservice: The permissive mode will operate 
the same as Single Band Permissive until the 
coordinated signal groups yield to a non-
coordinated movement. ALL signal groups will 
be allowed to reserve. After the coordinated 
signal groups yield once. 

Lost Time 
Total intersection time per cycle that is not effectively 
being used due to driver reaction time, acceleration, 
and deceleration at the start and end of active signal 
groups. This is typically three to four seconds per 
signal group, times the number of signal groups. 

- 

Phasing & Timing 
Control Type Defines control of movements as permissive; protected; 

protected / permissive; split; overlap; unsignalized (outer 
turns only using HCM 6th Edition) Control Type for each 
movement should be reviewed under the Phasing & Timing 
section and set to the following: 
 

• Permissive (Permitted) control requires motorists to 
choose acceptable gaps and/or yield to conflicting 
vehicles or pedestrian traffic streams. 

• Protected control assigns the right-of-way to 
turning drivers. 

• Protected/permissive control has a protected 
signal group assigning right-of-way to turning 
drivers that then transitions to the permissive parent 
signal group, requiring turning vehicles to yield. 
Permissive/protected control is modeled by 
selecting protected/permissive and changing the 
Lead/Lag setting to Lag. 

 

Turn Type 
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Note: In the HCM there are special requirements to ensure 
safe operations for Shared Thru/Left protected/permissive 
operations.  Shared thru/left are set to recall per the HCM. 
Max green for the left turn is equal to the min green of the 
thru since the left and thru are shared. Vistro will fix these 
settings if implemented differently to meet these 
requirements. 
 

• Split phasing control provides separation between 
signal groups within the same barrier and prohibits 
the signal groups from running concurrently. 

 
• Overlap control is a controller output that 

combines two or more non-conflicting signal 
groups. This is mostly used to combine signal 
groups that sit in separate barriers. A common 
example is when a right-turn movement has an 
overlap phase running concurrently with the 
“shadowing” left-turn movement on the cross-street.  

Note: Overlaps can be set for all movements to create 
advanced signal group combinations like those seen in tight 
diamond interchanges. 

Allow Lead/Lag 
Optimization 

Checkbox to allow for lead/lag optimization. Allow Lead/Lag 
Optimize 

Signal Group The signal group is the signal phase number.  
Auxiliary Signal Groups All signal groups serving the movement. When the Control 

Type is “Overlap” and the Signal Group for the Overlap 
phase is entered, the Auxiliary Signal Groups cell is active 
and allows selections of any phases with which this 
movement overlaps. 

X_Y phase setup 
convention in 
Synchro 

Lead/Lag Selection for Lead or Lag left turn for protected phasing. Lagging Phase? 
Minimum Green The minimum green time that the signal group will serve 

before changing to yellow. Note: Min Green value needs to 
be updated manually when the optimized split is 
determined. Different default Minimum Greens can be set 
for left and through movements in the Global Settings. 

Minimum Initial 

Maximum Green The maximum time that the signal group will be allowed to 
extend before it will max-out. A max-out will make a signal 
group eligible to terminate, even though it may not have 
gapped-out. This parameter when exported to RBC is 
reflected as Max1.  

- 

Amber Time a signal group will time an amber interval before 
advancing to red. 

Yellow Time 

All red Time a signal group will time red before a conflicting signal 
group will be allowed to begin timing. 

All-Red Time 

Split Amount of time allocated in the cycle for each signal group 
to time. The split includes the time it will take the green, 
yellow, and red intervals to time for each signal group. 

Total Split 

Vehicle Extension Allowed time between successful vehicle extensions before 
a signal group will gap out. This parameter may be referred 
to as passage in some controllers. 

Vehicle Extension 

Walk The minimum time a signal group will display a walk 
indication before advancing to the pedestrian clearance 

Walk Time 
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interval (flashing don’t walk). A signal group may not 
advance to yellow while the pedestrian movement is in the 
walk interval. 

Pedestrian Clearance Time a signal group will display a flashing don’t walk 
indication before advancing to solid don’t walk. A signal 
group may not advance to Yellow while the pedestrian 
movement is in the pedestrian clearance interval. Pedestrian 
clearance is estimated based on lane widths and median 
widths when Default Signalization is clicked. Note: This is an 
estimated crossing time and engineering judgment should 
be used to calculate field-based pedestrian clearance 
intervals. 

Flashing Don’t Walk 

Delayed Vehicle Green Used to establish Lead Pedestrian Intervals. This value is the 
amount of time that the vehicle green interval is delayed 
before the start of vehicle Green allowing the pedestrian 
walk interval to start first. 

- 

l1, Start-Up Lost Time Additional time needed to react to the initiation of the green 
signal and then accelerate. 

- 

l2, Clearance Lost Time The time between signal indication changes during which 
the intersection is not used by vehicles. 

- 

Coordinated Identifies the coordinate signal groups for the signal 
controller. 

Recall Mode 

Minimum Recall Signal groups flagged for this option will receive an 
automatic vehicle call regardless of actuation and time for at 
least its minimum green time. The green time may extend 
beyond the minimum if demand is present. 

Recall Mode 

Maximum Recall Signal groups flagged for this option will receive an 
automatic vehicle call and extension. The maximum green 
timer will unconditionally begin timing at the beginning of 
green. Normally, the maximum green timer will only time if 
there are opposing calls to the signal group. 

Recall Mode 

Pedestrian Recall 
(Pedestrian push-
button) 

Signal groups flagged for this option will receive an 
automatic pedestrian call and time for the full walk plus 
pedestrian clearance time. 
NOTE: This box does not need to be checked with fixed time 
signals to recall pedestrians, as this is automatically 
assumed. For non-fixed time signals, if this box is not 
checked and crosswalks are present, Vistro will automatically 
assume that this intersection has a pedestrian push button or 
pedestrian detector to activate a pedestrian call. 

Recall Mode 

Dual Entry When a signal group has a call in the next barrier group, 
concurrent phases in that barrier group may not have a call. 
In such cases, both the signal group with the call and the 
signal group with no call will begin timing when the barrier is 
crossed if both signal groups are flagged with Dual Entry. 
This feature is often used for through movement signal 
groups such that if one signal group is called, the signal 
group in the opposite direction will automatically serve, even 
if it does not have a call. 

Dual Entry 

Detector Checkbox to choose detector for the Signal Group Detector Phase 
Detector Location Distance upstream of stop bar of the leading edge of the 

detector. 
Detector 1 Position 

Detector Length Length of the detector. Detector 1 Size 
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I, Upstream Filtering 
Factor 

Adjustment factor to account for the effect of an upstream 
signal on vehicle arrivals to the subject movement group. 
This is currently user-defined. 

HCM Upstream 
Filtering Factor 

Exclusive Pedestrian Phase 
Pedestrian Signal 
Group 

The signal phase number for the exclusive pedestrian phase.  
All other pedestrian signal groups on each approach will be 
locked.  This pedestrian signal group must be added to the 
sequence. 

Ped Hold 

Pedestrian Walk The minimum time the exclusive pedestrian signal group will 
display a walk indication before advancing to the pedestrian 
clearance interval (flashing don’t walk). A signal group may 
not advance to yellow while the pedestrian movement is in 
the walk interval. 

Walk Time 

Pedestrian Clearance Time the exclusive pedestrian signal group will display a 
flashing don’t walk indication before advancing to solid don’t 
walk. A signal group may not advance to Yellow while the 
pedestrian movement is in the pedestrian clearance interval. 

Flashing Don’t Walk 

Arrival Type The arrival type selects the Platoon Ratio which describes the 
level of platooning quality arriving at the selected approach. 
The platoon ratio will be automatically updated based on the 
selection of Arrival Type per approach. 
Default = 3; Range = 1 – 6 (very poor – exceptional 
coordination) 
1 Very Poor Progression 
2 Unfavorable Progression 
3 Random Arrivals or Uncoordinated (default) 
4 Favorable Progression 
5 Highly Favorable Progression 
6 Exceptionally Favorable Progression 
 
The Arrival Type should be updated to match the field or 
desired conditions. See the HCM for further guidance on the 
selection of the Arrival Type and Platoon Ratio. 

- 

The following are PTV Vistro’s traffic signal controller results table and a short description of the 
parameter, as well as the Synchro Equivalent parameter, if applicable. For more detailed descriptions 
and units of each parameter, visit the Vistro help under Chapter 8. 

Table 2-2: Typical traffic signal controller results terminology 
Parameter Short Description Synchro Equivalent 
Lane Group Results 
X, Volume/Capacity for 
Lane Group 

The ratio of the total analysis volume (flow rate) to the 
capacity 

Volume to Capacity 
Ratio 

d, Delay for Lane 
Group 

Control delay for lane group Control Delay 

Lane Group LOS Level-of-service for lane group Level of Service 
Critical Lane Group  Lane groups with the highest flow rate are indicated as 

critical. 
- 

50th-Percentile Queue 
Length 

50th percentile queue length measured in the number of 
vehicles per lane 

- 

50th-Percentile Queue 
Length 

50th percentile queue length measured in feet per lane Queue Length 50th 
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95th-Percentile Queue 
Length 

95th percentile queue length measured in the number of 
vehicles per lane 

- 

95th-Percentile Queue 
Length 

95th percentile queue length measured in feet per lane Queue Length 95th 

Movement, Approach, and Intersection Results 
d_M, Delay for 
Movement 

Control delay per movement - 

Movement LOS Level-of-service for movement - 
Critical Movement The Critical movement on the approach - 
d_A, Approach Delay Average control delay by the approach Approach Delay 
Approach LOS Level-of-service for approach Approach LOS 
d_I, Intersection Delay Average control delay for the intersection Intersection Delay 
Intersection LOS Level-of-service for intersection Intersection LOS 
Intersection V/C Volume-to-capacity ratio for the intersection Max v/c Ratio 

Back to top 

4 Steps in creating signal controllers and 
performing local optimization 

4.1 Default Signalization 

After inputting the intersection geometry, crosswalk information (if applicable), and setting the primary 
controls and methods, PTV Vistro automatically sets up the traffic signal controller. Default signalization 
generates signal groups based on the control types.  As a result, this will generate your Sequence and 
Phase Diagram for common 3 and 4-leg intersections and is the preferred signal creation method 
for most intersections.  
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Figure 3-1: Typical Intersection settings needed  before clicking Default  Signalization 

 

Also, Default Signalization will use the timing parameters defined in Global Settings.  
Furthermore, the Major and Minor street Priority Scheme determines how to allocate the NEMA traffic 
signal phasing convention.  This is also customizable in Global Settings.  The first method of local 
optimization is to just click on Default Signalization.  Local optimization from Default signalization 
behaves differently from the initial setup: 

• The 1st time this is clicked, the splits and cycle length are locally optimized.   
• The 2nd time this is clicked, only the splits are optimized. The Cycle length will stay the same.  
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Figure 3-2: Default Signalization sets up your traffic signals 

 

Back to top 

4.1.1 Pedestrian Clearance (Flashing Don’t Walk) Estimation 

Default Signalization estimates pedestrian clearance or the flashing don’t walk (FDW) interval.  First, the 
calculation uses the pedestrian walking speed entered in the Intersection Settings section of the Traffic 
Control workflow.  These speeds are based on your agency’s recommendations and engineering 
judgment. 

If the Crosswalk Length is not set in the Intersection Setup workflow, PTV Vistro will automatically 
estimate the length using the roadway cross-sectional width.  This feature is extremely useful for 
planning situations.   
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Warning messages indicate missing crosswalk length values or if the entered crosswalk value is less 
than the minim lane widths of the leg.    

Figure 3-3: A sample of crosswalk warning messages 

 

In some cases, these can be ignored; however, FDW calculated estimates should be placed with 
engineering-based pedestrian clearance calculations.  And, crosswalk lengths should be verified and 
replaced based on new lane configuration modifications, as-built designs, field measurements, and/or 
measurements conducted in PTV Vistro using the measuring tool. 

Figure 3-4: Using the measuring tool to determine the crosswalk length for pedestrian 
clearance calculations. 

 

Back to top 
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Example 3-1: Understanding Pedestrian Clearance Calculations 

Impacts of crosswalk lengths can be simply tested and comparing 2 basic intersections with traffic 
signals setup using default signalization.  

1. Create intersection 1 and then leave the crosswalk lengths as 0 in the Intersection Setup 
Workflow.  Then click default signalization.   

2. Create intersection 2 and then enter a crosswalk length, perhaps 2x greater than the approach 
leg width, in the Intersection Setup Workflow.  Then click default signalization. 

3. Notice the difference in pedestrian clearance and interval calculations. 
4. Note the warnings on intersection 1 indicated that the crosswalk length is not entered and the 

values are less than the graphical width of the approach leg. 

Figure 3-5: Pedestrian Clearance Calculation Example 

 

Back to top 

 

4.2 Manual Signalization setups 

For non-standard 3- or 4-legged intersections configurations, intersections with more than 4 legs, 
intersections sharing traffic signal controllers, or requiring special signal groups, manual setup of 
signals may be required. 
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4.2.1 Assigning signal groups 

In cases where signal groups need set manually, at new intersections, a “0” signal group will be 
displayed.  After setting the control types for all movements, as needed, simply enter the desired 
signal group number for each movement.  Entering signal groups per NEMA Phasing schemes is not 
required, and you can enter any number combination. 

Once the signal group is entered, the timing and advanced parameters are unlocked for further 
modifications. 

Back to top 

4.2.2 Signal Groups Window 

In the main Traffic control workflow, only 1 signal group can be used per movement along with a 
combination of non-conflicting overlaps using auxiliary signal groups.  However, in special cases, such 
as a Texas Tight Diamond interchange functioning with 2 intersections on 1 controller (see Section 
3.3.1), or a hold phase for passive transit signal priority you may need extra signal groups to work 
with.  These extra signal groups have a split time, can be assigned to auxiliary signal groups, added to 
the sequence, and shown in the phase diagram. 

To create an extra signal group, open the Signal Groups window with the Plus Icon on the Traffic 
Control Toolbar .    This window list all of the Signal groups assigned to the controller and indicates 
which SGs are in use.  Once the signal groups setup and OK is clicked, they are accessible in the Traffic 
Control Workflow drop-down menus for Auxiliary Signal Groups and Sequence. 

Figure 3-6: Using the signal groups window. 

 

Back to top 
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4.2.3 Phase diagram 

The phase diagram graphically reflects the Signal Groups listed in the Phasing & Timing section and 
listed in the Signal Window, but also added to the Sequence.  The phase diagram lists the signal group 
numbers, green, yellow, red, delayed vehicle green, pedestrian interval timing, and split information.  
When hovering over a Signal Group, this information is summarized in a pop-up.  Also, in this pop-up, 
the Actual Green Time, and Green Time Start is displayed. 

Signal Group information can be displayed in the network editor when toggling the Show Signal 

Groups graphical display to visually show what signal group belongs to what approach. 

Also, the signal group bars represent the total splits for both vehicle and pedestrian signal groups and 
can slide to adjust the total split time. 

When the green color of the bars is lighter in color, this means that the signal group is added in the 
sequence, but not used locally at the active intersection. This is can because the signal group may be 
used at another intersection using the same controller (creating a clustered controller case, see 
Section 3.3.1) or because the signal group serves as a placeholder to reserve signal time (hold phase).  
See Figure 3-6. 

Back to top 

Example 3-2: Create a Passive Transit Signal Priority Signal Group 
(Hold Phase) 

In this example, create a basic intersection with signal groups 2, 4, 6, and 8 – and then a special transit 
signal group (SG 10) to account for a pre-timed placeholder on barrier  3 of the sequence phase 
diagram.  

1. Create intersection 1, set the intersection to fixed time actuation, and then click default 
signalization.   

2. Open the Signal Groups Window, click the “Plus” button and create Signal Group 10. 
3. In Signal Group 10, enter min and max green = 3, amber = 3, all red = 1, split = 7, walk and 

ped clearance = 0, and check max recall.  
Note: With Fixed Time actuation, max recall is not needed; however, it is good practice to 
check this if the actuation method is updated later.  

4. Click Ok. 
5. In the sequence, enter SG 10 in Ring 1, Barrier 3. 
6. In the Phasing & Timings section of the Traffic Control Workflow, adjust the splits of SG 2, 4, 6, 

8 to fit SG 10 within the cycle length, or utilize the Phase diagram. 
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Figure 3-7: Creating a Hold Phase Example 

 

Back to top 

 

4.3 Advanced Settings 

4.3.1 2 or More Intersections on 1 Traffic Signal Controller 

Placing 2 or more intersections under 1 controller (clustered traffic signal control) can simply be 
achieved by using the Controller ID drop-down list in the Intersection Setting section of the Traffic 
Controller Workflow and then selecting another controller.  This practice is often used with closely 
spaced intersections (see Intersections 225 and 228 sharing Controller ID 225 in the Austin Texas 
Example in the Help->Open Examples Directory->Signal Optimization Folder, or for a Texas Tight 
Diamond, as shown in the ->Signal Controller Folder -> Tight_Diamond_Core_Overlaps for 
Intersections 1 and 2 sharing Controller ID 1.  Additionally, many of the Examples in the ->Alternative 
Intersections folder applications of this practice. 

Often, the Signals Group Window will have to be utilized to set up additional Signal Groups on an 
approach represented at an adjacent intersection, for example, Minor Street SG 4 at one intersection 
and SG 8 at another intersection (see Section 0).   
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Also, the same sequence and phase diagram are utilized at each intersection location reusing the 
controller. All Signal Groups must be placed in the sequence (from any intersection reusing the 
controller) for the signal group to be visible in the Phase Diagram.  When the green color of the bars in 
the Phase Diagram are lighter in color, this means that the signal group is added in the sequence, but 
not used locally at the active intersection. This is can because the signal group may be used at another 
intersection using the same controller. This is very useful when setting up multiple intersections on the 
same controller. 

Tip#1: Utilizing the Graphic Parameter Show Intersection Info -> Controller Number will 
confirm which intersections share the same traffic signal controller. 

Tip#2: Turning on the Show Signal Groups Graphic Parameter  will show the signal group 
numbers per movement in the network editor.  This is very useful when setting up multiple 
intersections on the same controller. 

 

4.3.2 Pedestrian fixed-time, recall, and push-button settings 

Pedestrian crossing signal group in Vistro can be configured in several ways and depends on fixed-
time or actuated control types.  Ultimately, utilizing the Vissim Preview under Help will confirm if the 
configuration is correct. 

Fixed Time:  Under this configuration, pedestrian signal groups will automatically be set to recall and 
pedestrians will be served. 

Semi-actuated: Under this configuration, the major street pedestrian signal groups will recall 
automatically; however, you may choose to manually click Ped Recall for clarity.  The minor street 
pedestrian signal groups may operate pushbutton-stye or under recall.  This choice is selected in the 
Pedestrian Recall Checkbox in the Phasing and Timing section of the Traffic Control Workflow.   

If left unchecked, the pedestrian signal group will be pushbutton controlled and only be called when a 
pedestrian is present via a pedestrian probability calculation based on the HCM.  In PTV Vissim a 
detector will be created to simulate the pushbutton.  If this checkbox is checked, the pedestrian phase 
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will recall every cycle and the signal vehicle group cannot gap out before the ped phase is complete, 
or the vehicle phase cannot be skipped. 

Fully-actuated: Under this configuration, all pedestrian signal groups must be reviewed, requiring a 
choice is in the Pedestrian Recall Checkbox in the Phasing and Timing section of the Traffic Control 
Workflow.   

If left unchecked, the pedestrian signal group will be pushbutton controlled and only be called when a 
pedestrian is present via a pedestrian probability calculation based on the HCM.  In PTV Vissim a 
detector will be created to simulate the pushbutton.  If this checkbox is checked, the pedestrian phase 
will recall every cycle and the signal vehicle group cannot gap out before the ped phase is complete, 
or the vehicle phase cannot be skipped. 

Back to top 

Example 3-3: Pedestrian Push button and Recall Settings 

The Chapel Hill Small Corridor example under Help -> Open Examples Director -> Signal 
Optimization explains showcases the pedestrian push button or recall configuration.  In this example, 
Intersection #1 and #2 are set to semi-actuated with pushbuttons on the north and south approach 
(not checked for the Pedestrian Recall parameter).  Intersection #3 is fully-actuated, and all approaches 
operate with a pushbutton. 

For Intersection #1 in this example Reviewing Signal Groups 4 and 8’s Actual Green Time results in 
the Lane Group Calculations section of the Traffic Control Workflow, it is apparent that the green time 
is less than the Green time under a Fixed time Configuration.   

1. Observe the northbound and southbound Actual Green Time approach results with 
pedestrian recall unchecked (push button).  The result is 14 seconds.  This means that due to 
the pedestrian probability influences of a push button, some cycles truncate the green time as 
expected.  The extra 5 seconds of green time is given to the major street. 

2. Next, On the Volume Workflow, change the pedestrians to 50 for northbound and 
southbound approaches under pedestrians (v_do and v_di inputs).  Back on the Traffic 
Control Workflow observe that the Actual Green Time results are now 18 seconds for both 
northbound and southbound approaches, meaning that the vast majority of Cycles will receive 
a pedestrian push button call. 

3. Finally, check the pedestrian recall box (no push button) for both the northbound and 
southbound approaches.  Now, the Actual Green Time results are 19 seconds, meaning that 
the signal group is recalled to the maximum green every cycle. 
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Figure 3-8: Example of Pedestrian Push Button’s influence on serviced Actual Green Time 

 

Back to top 

 

4.3.3 Exclusive Pedestrian Phase 

PTV Vistro also includes build-in functionality to analyze exclusive pedestrian phases.  Some local 
names for such a phase are the Barnes Dance or Pedestrian Scramble.  These phases allow all 
pedestrians to cross on one pedestrian phase while vehicular traffic has all-red signals.  Additionally, 
this safe and efficient crossing option is useful for intersections with high pedestrian crossing volumes 
and multiple transit stops requiring a multi-stage crossing.  See Scenario 2 in the Signalize Midblock 
Crossing example located under Help -> Open Examples Director -> Pedestrian and Bicycles and 
the supporting documentation. 

To create this configuration, visit the Exclusive Pedestrian Phase section of the Traffic Control 
Workflow, create a pedestrian signal group, assign a pedestrian walk time and clearance, and then 
add the signal group into the sequence.  Once added here, the Phase Diagram will display the 
Exclusive Pedestrian Phase.   

Note: Once an exclusive pedestrian phase is added, all other pedestrian signal group bars will 
disappear and the data entry will be locked for the walk and clearance input from the Phasing and 
Timing section. 

In some special cases, cities may need to utilize exclusive pedestrian phases along with additional 
traditional approach based pedestrian phases.  In this case, create an intersection with regular 
pedestrian crossing phases.  Then create a special “placeholder” phase (hold phase) using the Signal 
Group Window, as discussed in Back to top 
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Example 3-2 – then add this special signal group to the sequence.  This will conservatively replicate the 
exclusive pedestrian phases along with traditional approached based pedestrian signal groups.  With 
this method, all conflicting pedestrian volumes will still be allocated to the primary approach-based 
pedestrian signal groups and not allocated to the hold phase.  This will lead to greater impacts on the 
vehicle results.  Currently, no HCM guidance is available for combining exclusive pedestrian phases 
with the traditional approach based pedestrian phases, and judgments should be made to interpret 
analysis results. 

Figure 3-9: Exclusive Pedestrian Phase Setup and Vissim Simulation 

 

 

Back to top 

4.3.4 Delayed Vehicle Green 

Leading pedestrian intervals (LPIs) at traffic signals are wide-spread active transportation plan features. 
LPIs can be achieved by requiring no additional signal phases and can utilize the Delay Vehicle Green 
Parameter. 

The Delayed Vehicle Green parameter in the Phasing & Timing section of the Traffic Control 
Workflow Panel, inserts a red time at the start of the signal group split, as shown in the Phase 
Diagram.  This delays the vehicular start of green, which can be observed in the Lane Group 
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Calculations section of the Traffic Control Workflow Panel.  This delay time allows pedestrians and 
cyclists to lead.   

Note:  LPI modeling is setup for fixed-time controllers only. However, the delayed vehicle green 
parameter can be applied to actuated pedestrian approaches, but this will call the delayed vehicle 
green every cycle – even without pedestrian “calls”.  Currently, no HCM guidance is available for 
actuated leading pedestrian interval calculations and judgments should be made to interpret 
analysis results. 

Furthermore, leading pedestrian intervals are exported to PTV Vissim automatically.  See the example 
documentation in Help->Open Examples Directory ->Pedestrians and Bicycles -> Lead Pedestrian 
Interval for more detailed information on how this is coded in PTV Vissim’s .RBC file via the ANM 
export. 

The Delay Vehicle Green parameter has other advanced applications, such as to produce a Montreal 
Leading Thru or to emulate a stage-based controller in a ring-barrier environment. 

Back to top 

Example 3-4: Create and LPI with Delayed Vehicle Green 

In this example, create an LPI utilizing the Delayed Vehicle Green Parameter.  

1. Create a basic intersection 3 leg intersection.  Set 200 vehicles on each approach, on 100 
pedestrians on each crosswalk. 

2. Set the intersection to fixed-time and create default signalization 
3. Set the Delayed Vehicle Green parameter for 10 seconds on each approach and adjust the 

max green timing to compensate. 
4. Under the Lane Group Calculations observe the Green Time Start results and compare them 

to the Phase Diagram. 
5. Finally, under Simulation->Preview in Vissim observe the Leading Pedestrian Interval in 

Vissim. 
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Figure 3-10: Delayed Vehicle Green Settings. 

 

Figure 3-11: PTV Vissim Leading Pedestrian Interval Simulation 

 

Back to top 
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4.3.5 Overlaps 

Overlaps can be selected under the Signal Group’s control time for all movements.  This links the 
signal timing together of the parent signal group and the overlapping auxiliary signal group. 

A common configuration is overlapping a protected left-turn signal group with a non-conflicting right-
turn signal group. 

Additionally, overlapping signal groups provide an opportunity to create a special or custom 
configuration like that shown in the Texas Tight Diamond in Figure 3-6 (also shown in Help->Open 
Examples Directory ->Signal Controller -> Tight Diamond Core Overlaps and described in the 
documentation).   

Back to top 

4.3.6 Montreal’s Leading Thru Configuration with Overlaps 

Also, Overlaps can be used to create leading thru phases on shared lane groups, commonly utilized in 
Montreal, Canada. Typically, in this case, shared-lane turns with thru movement would have the same 
Permissive signal group.  However, in Montreal, the thru will receive a green indication first, and the 
shared left and right turning vehicles are required to wait until their green indication.  This is often 
intended to protect crossing pedestrians, thus providing a leading pedestrian interval under this 
situation.   

To achieve this in Vistro, the Overlap Control Type can be assigned to the left and right movements on 
the shared lanes.  This unlocks the usage of Signal groups for left and right turn movements.  Then, by 
utilizing the Delay Vehicle Green parameter, the turns can be held in 1 signal group, while the thru 
leads first in another signal group.  See the following figure and example.  

Note: This configuration does result in an ICA check error since the application is not conventional.  
The message indicates the more than 1 signal groups control the same shared lane; however, that is 
exactly what needs to be achieved in this configuration.  Importantly, interpretation of the results is 
needed, as green time will only be calculated for the lane groups, not for each movement per HCM. 
Due to this, the thru green time prevails in the lane group, as it is the highest, and the results of the 
turning movements are calculated with a higher green time than represented in the field conditions.  

Back to top 

Example 3-5: Creating Montreal’s Leading Thru Configuration with 
Overlaps and Delayed Vehicle Green 

In this example, create an intersection utilizing Montreal’s leading thru configuration with Overlaps and 
shared turning lanes.  The thru signal groups are set to 6, and the turning signal groups are set to 2 
with a delayed vehicle green of 7 on each turn.  

1. Create a basic intersection and set the Major Street lane configuration Shared Left/Thru and 
Shared Thru/Right. 
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2. Next, instead of creating default signalization, set the northbound and southbound 
movements to both signal group 6.  Then on the northbound and southbound right and left 
movements, set the Control Type to Overlap. 

3. Next, set the signal group for both the right and left turns to 2.  Under the Auxiliary Signal 
Group settings, ensure that signal group 6 is NOT checked, thus resulting in both Signal group 
2 as both the parent and auxiliary. 

4. Then, set minimum and maximum green, amber, red, and split times for all signal groups. 
5. Then, set the Delay Vehicle Green time to 7 seconds for both the left and right turns. 
6. Finally, review the pedestrian timing, coordination, recalls, detectors, and dual entry settings as 

needed. 

Figure 3-12: Create Montreal’s Leading Thru Configuration with Overlaps and Delayed Vehicle 
Green 
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4.4 Local and Automatic Optimization 

After setting up the intersection settings in the traffic control tab it can be Local Optimized.  Local 
optimization will optimize the intersections individually, and will not consider coordination. 

The first method of local optimization is to just click on Default Signalization  on the Traffic Control 
Workflows toolbar (see Figure 1-3).  Local optimization from Default signalization behaves differently 
from the initial setup: 

• The 1st time this is clicked, the splits and cycle length are locally optimized.   
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• The 2nd time this is clicked, only the splits are optimized. The Cycle length will stay the same.  

The second method for local optimization is to go to Signal Control -> Local Optimization. This can 
be conducted before or after default signalization. In this menu, the following can be set: 

• Objective function strategies from “volume/Capacity balancing” or “minimizing the critical 
movement delay”. 

• Optimize splits only, or splits and cycle times. 
o Selecting splits and cycle times unlocks an option to select a cycle length range and 

step size for each iteration, as well as a try set if your intersection has a preferred 
cycle time array or a specific cycle length in mind.  

• Locally optimize all intersections  
• Save the settings for next time. 

Figure 3-13: Local Optimization Menu 

 

The third method is to click on the Optimize Split and Cycle Time button  on the Traffic Control 
Workflows toolbar (see Figure 1-3).  Here the selection of parameters is similar to the previous 
method; however, you can’t optimize all intersections. 

Finally, the fourth way is to optimize locally is with the Automatic Optimization toggle 
on the Traffic Control Workflows toolbar (see Figure 1-3).  This optimizes the splits 

only.  When checked, updates to lane configurations, volumes, control types, or other timing settings 
will automatically optimize the signal.  When unchecked the intersection won’t optimize with each 
update made. This sets Vistro apart from other software, such as Synchro where changes automatically 
optimize the signal. 

Back to top 

4.5 Renumbering Controller IDs 

Matching controller ID numbers to an agency number scheme or just organizing your traffic controller 
numbers is possible in PTV Vistro.  In some cases, merging in a model from another network or 
importing an OpenStreetMap file may produce intersection numbers and traffic signal controller IDs 
that need to be revised.  Or perhaps extra intersections were created and then deleted and the order 
of intersections and controller IDs need to be reordered. There are 2 methods to modify a traffic signal 
controller ID number.   

The first method is to simply change the Intersection Number, which can only be achieved on the 
Intersection Setup Workflow in the Number field.  If the revised number entered is an available 
Traffic Signal Controller ID number, then Vistro will automatically change the Controller ID to match 
the Intersection ID.  If the Controller ID (and/or intersection number) is not available, the conflicting 
controller (and/or intersection) must be temporarily reassigned to a vacant number to avoid the 
conflict.  Renumbering a Controller ID only requires method 2. 
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The second method is to go to Signal Control -> Edit Controllers… and renumber only the traffic 
signal controller ID.  This window provides a list of all traffic signal controllers with numbers in the ID 
column which is editable to change the controller ID number.  The only other editable field in this list is 
the controller Description.  This field enables the entry of notes about the controller, just as inspection 
dates, controller manufactures, or classification types.  Next, the intersection number shows where the 
traffic signal controller is applied.  Multiple intersection numbers indicate that the traffic signal 
controller is used at multiple locations. If there are multiple locations, the intersection name will be 
displayed only for the first ID.  Also, the Coordination Group is displayed to show what corridor or 
signal system the controller resides in.  To learn more about Coordination Groups see Section 4.1.  
These columns can be filtered or sorted by clicking.  To filter by value, enter the value, then hold down 
shift to select multiple controllers to show. 

Figure 3-14: Edit Controllers Window with Location Filtering 

 

5 Network Optimization 
PTV Vistro’s powerful coordination tools can optimize entire districts, corridors, and precise routes with 
our user-friendly graphical-user interface, resulting in accurate and fast Green Wave optimizations. PTV 
Vistro provides you with two network optimization methods: 

 Traditional zonal coordination using “Coordination Groups”; and 

User-defined and flexible optimization corridors using “Routes”. 

5.1 Coordination Groups 

In PTV Vistro, setting intersections to the same Coordination Group (similar to Zones in Synchro), 
optimizes the intersections’ offsets, in addition to the cycles and splits, if desired. This zonal 
optimization calculates the Green Wave between intersections in that Coordination Group. Using 
multiple Coordination Groups can optimize a combination of districts and corridors as individual 
groups, or all at the same time using basic equal coordination to a City grid or straight-line corridors.  
By default, 1 Coordination Group is included in a new Vistro file; however, more can be added. 
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Note: A Coordination Group must be assigned to an intersection to be considered for Network 
Optimization.  If a Coordination Group is not assigned, the intersection will not be recognized in the 
Network Optimization process.   

Tip: To increase efficiency when modeling, it is best to have all signal coordination groups created if 
known ahead of time, then allocated Coordination Groups can be achieved while creating and 
modifying traffic signal controllers. 

Back to top 

5.1.1 Create a Coordination Group 

To view, add, or modify the Coordination Groups, go to Signal Control -> Edit Coordination groups.  
In this menu: 

• New Coordination Groups are added with the plus icon ; 
• Deleted with the trash can icon ; and 
•  Renamed in the Name field. 

Once a series of controllers are assigned a Coordination Group (see Section 0), such as along a 
corridor or in a city district grid, this menu can be revisited to assign a Master Intersection Controller 
(see Section 0). 

Figure 4-1: Adding or Modifying Coordination Groups 

 

-> 
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5.1.2 Assign Coordination Group 

To assign a Coordination Group to each intersection, click on the intersection, navigate to the Traffic 
Control Workflow, and then select the drop-down list from the Signal Coordination Group 
parameter – and then select the desired Coordination Group.  
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Figure 4-2: Assigning a Coordination Group to an Intersection 

 

Tip #1: To identify the Coordination Group set on each intersection in the network editor, click on the 
Show Intersection Info graphic parameter and select the Coordination Group option.  This will 
display which intersections have been assigned a group and help provide a quick quality control 
check.  If a group is not assigned to an intersection, the intersection will be blank. 
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5.1.3 Selecting a Master Controller 

Selecting a Master Controller in the Coordination Group is optional to network optimization; however, 
many agencies prefer to introduce a master controller clock within a series of coordinated signals.  If 
an intersection is set to the Master Controller, the offset reference is locked to 0 seconds when set.  
All other controllers in the same Coordination Group will adjust relative to the Master Controllers 0 
second offset automatically. 

Tip #1: To identify the intersection controller number in the network editor, click on the Show 
Intersection Info graphic parameter and select the Controller Number option. 

Tip #2: To identify the Coordination Group set on each intersection in the network editor, click on the 
Show Intersection Info graphic parameter and select the Coordination Group option. 
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Example 4-1: Creating and Assigning a Coordination Group, and 
selecting a Master Controller 

This example, will create a Coordination Group, assign it to a series of intersections, and select an 
intersection Master Controller.    

1. First, go under Signal Control -> Edit Coordination groups to add a new coordination group.  
Click on the plus icon to create Coordination Group 2.  Name the coordination group 
“Example”.  Then click “OK” to save the Coordination Group. 

2. Next, Create 2 closely spaced intersections then connect adjacent Leg Handles. 
3. Next, go under Signal Control -> Default Signalization.  Then, click on “Create Default 

Signalizations” to create Signal Groups for each intersection simultaneously. 
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4. Notice at each intersection the Signal Coordination Group parameter shows a “-“, indicating 
that no Coordination Group is defined.  Define Coordination Group 2 for each intersection. 

5. Turn on the Graphic Parameter Show Intersection Info -> Coordination Group and confirm 
that both intersections are on Coordination Group 2. 

6. Place a 3rd intersection, using copy and paste to the right of the right-most intersection (Right-
click on the main Intersection Grip to open the context menu, select Copy Intersection, and 
then right-click on a location to Paste the Intersection using the context menu. 

7. Notice that this intersection is already assigned Coordination Group 2 when using copy and 
paste.  This could be used as a shortcut when setting up intersections. 

8. Connect the new intersection’s Leg Grip with the middle intersection. 
9. Turn on the Graphic Parameter Show Intersection Info -> Controller Number and determine 

the Controller ID of the right-side intersection.  Renumber the signal controller ID numbers, as 
needed (see Section 0).  

10. Click on each intersection and enter the Offset values of “5, 10, and 15” seconds from left to 
right, for each intersection under the Intersection Settings section in the Traffic Control 
Workflow.  Leave the rightmost intersection active, with the Offset value viewable in the 
Intersection Settings section. 

11. Go to Signal Control -> Edit Coordination groups, select Coordination Group #.  Under the 
Master Controller drop-down list select the rightmost intersections Controller ID number.  
Before clicking “ok” to accept the changes, take note of the Offset value in the Intersection 
Settings section set for 15 seconds.   

Figure 4-3: Assigning a Master Controller in a Coordination Group. 

 
12. Then, click “OK”. Notice that the Offset value change to 0 seconds.  This value will be locked.  

Note: the new Offset values calculated for the other “non-master” intersections.  
13. Go back to the rightmost intersection, and attempt to change the Offset value to something 

other than 0.  Note, the error by hovering over the red “X”.  This value can not be updated 
since the controller is the master. 

 

 
Back to top 
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5.2 Network Optimization Settings and Running 

After Coordination Groups are created, the network and be optimized Using the Network Optimization 
tools in PTV Vistro.  Go to Signal Control -> Network optimization, to open the Network 
Optimization Settings menu. This menu has the following parameters with descriptions.  More 
information can be found in the Vistro Help manual under the Help menu: 

Table 4-1: Network Optimization Settings and Description 

Parameter Short Description 

Objective function In these fields, the weights for delays and stops can be defined The formula is 
used to determine the Performance Index for optimization.  Generally, the 
stop weight is a low number because this is the total number of stops across 
the intersections being optimized.   

Genetic method This method is a more robust and customizable method that includes closing 
criteria  The maximum number of iterations can be selected as well as 
Population Size. Generally speaking, the larger the population size the better 
the optimum solution.  The number of runs without improvement and an 
improvement percentage threshold represent the closing criteria to the 
method. 

Hill Climb method This method is a simpler and faster method but the optimization may close 
without finding the optional solution if the number of runs is low. Here the hill 
climb defaults to only 10 starting solutions and genetic defaults to 100 
iterations with the closing criteria.   

Coordination Groups to 
Be Optimized  

One, more, or All Coordination groups can be selected. To select a few 
groups hold down SHIFT and click. 

Optimize Split and/or 
Cycle Time 

Here, choose if to optimize, Splits Only, or Splits and Cycle Time.  And if 
you only want to optimize offsets just leave the splits and cycles unchecked. 

When selecting Splits and Cycle Time and upper and lower bound, along 
with step size can be entered. 

Use Offset Optimization Choose if the Offsets between traffic signal controllers should be optimized 
and the precision of the optimization. 

Allow Lead/Lag 
Optimization 

Optimization will find the best solution for the left-turns in either a leading or 
lagging configuration.  If your agency does not allow lags, then just leave it 
unchecked so all of your signal group control types on your left-turns will stay 
as Lead.   

Note: This setting is dependent on if the Allow Lead/Lag Optimization 
checkbox is checked in the Phasing and Timing Section of the Traffic 
Control Workflow.  If the box is checked here, then the optimization is 
possible.  If it is not checked, then Lead/Lag optimization for that intersection 
is not available. 

Save Settings After modifying the parameters on the Network Optimization Menu, click 
Save Settings to retain your preferences. 



 PTV GmbH Feb-23 Page 42/48 
 

Run Optimization After modifying the parameters on the Network Optimization Menu, click Run 
Optimization to start the Network Optimization Process. 

Figure 4-4: Network Optimization Menu 

 

Also, the Network Optimization window is accessible in the Network Optimization Workflow’s, by 
clicking the Network Optimization button.  This workflow is discussed in more detail in Section 0. 

Network Optimization process begins after the Run Optimization is clicked.  The Optimization 
Progress window will appear cycling through optimization calculations probing each specified cycle 
length.  The Best Score will be displayed during the optimization process based on the objective 
function.  The lowest Cycle length with the Best Score will be selected. 

Note: Depending on the optimization settings, closing criteria, network size, and the number of 
Coordination Groups selected at 1 time, Network Optimization could be quick or take a few minutes to 
process.  It is recommended that you save your file (or a copy of your file) before running 
Network Optimization in case you wish to exit the process.  Occasionally, the screen will remain black 
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for a few moments or show as non-responsive.  Be assured, optimization is working in the background, 
and your patients may be required for larger networks.  Using the Allow Reduction of Optimum Split 
and Minimum Improvement parameters greatly increases processing time. 

Figure 4-5: Network Optimization Progress Window 

 

Back to top 

5.3 Routing 

PTV Vistro’s Traffic Signal Optimization Routes enhances a Coordination Group’s Green Wave 
optimization by taking the traditional methodology further. With Routes, you can optimize a corridor 
that makes a turn or has a higher priority Weight over another route. 

A typical application of Optimization Routes is identifying several corridors by drawing a Route object, 
and then optimizing it with or without assigned priority weights within a City grid or district 
Coordination Groups. This will establish key arterial corridors within the Coordination Group – and 
increased functionality over traditional zonal coordination, by tying a series of movements together.   

Also, Routes are necessary to visualize the Time-Space Diagram shown on the Network Optimization 
Workflow (see Section 0). 

To draw a route, left-click the Route button , and then start with the Leg End or Intersection Grip 
at one end of the network and drag to another Leg End or Intersection Grip, and double left-click to 
complete the Route. A route can also be manually defined by left-clicking once on each Intersection 
Grip until the last point, ending the Route with a double left-click.   Routes can also be redefined by 
dragging the intermediate points to another intersection with a left-click. More information on drawing 
routes can be found in the Turning Routes 2-Way to 1-Way Conversion example documentation 
located under Help->Open Examples Directory ->Signal Optimization folder.  After the Route is 
created it will be displayed in the Network Optimization Workflow (see Section 0). 

Additionally, the linked video indicates how the draw a route: Drawing a Route. 

https://youtu.be/lD7jPFudC8E
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Figure 4-6: Drawing a Traffic Signal Optimization Route 

 

Back to top 

5.4 Network Optimization Workflow and Time-Space Diagrams 

The Network Optimization Workflow  summarizes every Route in the network (see Section 
0), and the Time-Space Diagram along that Route and/or Reverse Route.  With at least 1 Route 
defined, the Network Optimization Route table will be populated.  Here a Name can be given to the 
Route, typically indicating the direction as well as a Weight.   The weight is a factor that gives priority 
to the Routes movements at each intersection in Network Optimization.  The higher the Weight, the 
higher the priority. 

A Routes Reverse Direction can be quickly created by right-clicking on the route in the table to 
open the context menu.  This will create an exact copy of the route.  When creating a reverse direction, 
be aware of one-way roadways.  Also, this context menu contains an option to Delete the Route or 
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Copy and Paste route text. Copy and Paste do not copy the Route.  An example of Route Setup, 
Reverse Directions, and with Weights is shown in the Atlanta TIA Mitigate example under Help->Open 
Examples Directory ->TIA. 

The following are additional parameters of the Network Optimization Workflow as shown with labels in 
Figure 4-7: 

1. The Time-Space Diagram can be visualized using the Maximum Flows or Arterial Bands in 
the Signal Time-Space Diagram Mode drop-down menu. 

2. The scale of the Time-Space Diagram can be set with the Max Signal Time(s) parameter. 
3. The Time-Space Diagram can show the Route in the Reverse Direction if one is created by 

checking the Show Reverse Direction route. 

The Time-Space Diagram also shows the following information. 

4. Spacing between intersections along the Route. 
5. Intersection and Controller ID numbers, and the  
6. Cycle Time, Offset, and Coordination Group number 
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Figure 4-7: Time-Space Diagram on the Network Optimization Workflow 

 

Additionally, Time-Space Diagrams can be printed by going to File -> Print report.  On the “Select 
Report” tab, select the Time-Space Diagram report under the Graphical Reports section on the right 
side of the window. 

Back to top 
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6 Additional Special Cases 

6.1 Transit or Bicycle Active TSP 

Transit queue-jumps utilize short, dedicated lanes.  In these lanes, transit vehicles move to a priority 
position and bypass queued vehicles on the approach. Once in position, detection places a priority 
call to the transit signal group. Estimating active TSP in Vistro provides a general understanding of 
queue jump operations. This begins by adding a special transit leg to access traffic volumes and 
detection parameters. 

Furthermore, importing PTV Vistro into PTV Vissim or Visum migrates your special transit leg, 
detection, and signal groups into an advanced transit planning tool.  These advanced transit planning 
toolsets include TSP elements, such as phase omits, minor street truncations, and signal corridor 
coordination. The following video tutorial shows how to create active TSP in PTV Vistro, building from 
the passive TSP example: 

Active TSP estimation in PTV Vistro 

Figure 5-1: Transit or Bicycle Active TSP Self-Tutorial (click for video) 

 

Back to top 

7 Migration from Synchro 

7.1 Global Settings 

Make sure global settings are complete before Merging a Synchro file. See Section 1.1 for 
recommendations.  More Information Coming Soon 

https://youtu.be/maDaGs-K3N4
https://youtu.be/maDaGs-K3N4
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Back to top 

7.2 Importing a Combined .csv 

Information Coming Soon 

Back to top 

7.3 Merge 

Information Coming Soon 

Back to top 

7.4 Update 

Information Coming Soon 

Back to top 
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